My computer wont load the mid cam on ocsurfcam.com.

the page freezes for a second then gives me an error message which i click on and it spits out all this nonsense:

--------

Java Plug-in 1.6.0_26
Using JRE version 1.6.0_26-b03-384-10M3425 Java HotSpot(TM) 64-Bit Server VM
User home directory = /Users/jeffrusso
----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------


load: class ShowServerPush.class not found.
java.lang.ClassNotFoundException: ShowServerPush.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Ap plet2ClassLoader.java:252)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(P lugin2ClassLoader.java:250)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Pl ugin2ClassLoader.java:180)
at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Pl ugin2ClassLoader.java:161)
at java.lang.ClassLoader.loadClass(ClassLoader.java:2 47)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plu gin2ClassLoader.java:687)
at sun.plugin2.applet.Plugin2Manager.createApplet(Plu gin2Manager.java:3046)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionR unnable.run(Plugin2Manager.java:1498)
at java.lang.Thread.run(Thread.java:680)
Exception: java.lang.ClassNotFoundException: ShowServerPush.class

--------

i have a Mac pro running 10.6.8. everything is up to date including java. any ideas what needs to be done?